• Главная
  • Поиск
    •  
  • Здравствуйте, Гость

Автор Тема: 400 Bad Request  (Прочитано 1258 раз)
  • *
  • Сообщений: 33
« : 19 Май 2014, 14:02:56 »
Всем привет, вот проблема у меня возникла 400 Bad Request
ответ хостера: Скорее всего это связано с лишними символами %d, попробуйте отключить ЧПУ, либо использовать другой шаблон.
кто знает как лечить?
Спасибо
« Последнее редактирование: 19 Май 2014, 14:05:37 от Maxrom »

Оффлайн Dis
  • Admin
  • *****
  • Сообщений: 987
    • Шаблоны и плагины Osclass
« Ответ #1 : 19 Май 2014, 14:07:43 »
Да кириллица в ЧПУ так режется, используйте транслит.
в файле /oc-includes/osclass/formating.php
После
function remove_accents($string) {
if ( !preg_match('/[\x80-\xff]/', $string) )
return $string;
Добавьте код ( пример):
if (is_utf8($string)) {
$chars = array(
"А"=>"a","Б"=>"b","В"=>"v","Г"=>"g",
"Д"=>"d","Е"=>"e","Ж"=>"j","З"=>"z","И"=>"i",
"Й"=>"y","К"=>"k","Л"=>"l","М"=>"m","Н"=>"n",
"О"=>"o","П"=>"p","Р"=>"r","С"=>"s","Т"=>"t",
"У"=>"u","Ф"=>"f","Х"=>"h","Ц"=>"ts","Ч"=>"ch",
"Ш"=>"sh","Щ"=>"sch","Ъ"=>"","Ы"=>"i","Ь"=>"",
"Э"=>"e","Ю"=>"yu","Я"=>"ya","а"=>"a","б"=>"b",
"в"=>"v","г"=>"g","д"=>"d","е"=>"e", "ё"=>"e","ж"=>"j",
"з"=>"z","и"=>"i","й"=>"y","к"=>"k","л"=>"l",
"м"=>"m","н"=>"n","о"=>"o","п"=>"p","р"=>"r",
"с"=>"s","т"=>"t","у"=>"u","ф"=>"f","х"=>"h",
"ц"=>"ts","ч"=>"ch","ш"=>"sh","щ"=>"sch","ъ"=>"y",
"ы"=>"i","ь"=>"","э"=>"e","ю"=>"yu","я"=>"ya",
" "=> "_", "."=> "", "/"=> "_", "-" => "_");
$string = strtr($string, $chars);
}

  • *
  • Сообщений: 33
« Ответ #2 : 19 Май 2014, 14:27:06 »

Parse error: syntax error, unexpected $end in /var/www/vtabloco/data/www/vtablo.com.ua/oc-includes/osclass/formatting.php on line 229

Оффлайн Dis
  • Admin
  • *****
  • Сообщений: 987
    • Шаблоны и плагины Osclass
« Ответ #3 : 19 Май 2014, 15:00:28 »

Parse error: syntax error, unexpected $end in /var/www/vtabloco/data/www/vtablo.com.ua/oc-includes/osclass/formatting.php on line 229
Значит Вы код вставили так, наверняка не весь, скобка не закрыта.

  • *
  • Сообщений: 33
« Ответ #4 : 19 Май 2014, 15:11:09 »
все проверил даже отступы сделал и ничего 400 Bad Request

  • *
  • Сообщений: 33
« Ответ #5 : 19 Май 2014, 17:34:37 »
проблема решена
ЧПУ отключено, но файл .htaccess изменен вне Osclass и не был удален
отключил ЧПУ и все стало как и прежде :)
Спасибо !!!

PS только вот не знаю а файл .htaccess удалять надо или нет?

Оффлайн Dis
  • Admin
  • *****
  • Сообщений: 987
    • Шаблоны и плагины Osclass
« Ответ #6 : 25 Май 2014, 14:32:21 »
Решение проблемы было написано во втором сообщении, 100% рабочий вариант с ЧПУ.

 


test